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Introduction
• Image WM is a Macintosh application program, which is specifically designed for Morris water
maze test.
• Image WM is based on a public domain software, NIH Image 1.62, developed by Wayne

Rasband at the National Institutes of Health. Thus, basic knowledge for using Macintosh and

NIH Image is required. NIH Image and the manual to learn how to use NIH Image is available

on the Internet from http://rsb.info.nih.gov/nih-image/index.html. When you publish data

obtained by Image WM, you should state your utilization of NIH Image, as indicated in NIH

Image manual.

• Do not distribute the software without permission. The use of the software is strictly restricted
inside the laboratories that have permission to use.

Hardware Configuration
To get started, you need (a) Macintosh computer, (b) video capturing device, (c) video camera,

(d) a tool which mount camera on ceiling, etc. and (e) behavioral apparatus.

(a) Macintosh: Power Macintosh, iMac, iBook or Power book is needed. RAM should be larger

than 64 MB. System 7.5 or later should be used.

(b) Video capturing device: Scion LG-3 (approximately $850) board is recommended, if your

Macintosh has PCI bus. If your Macintosh has USB port, QuickTime compatible video capturing

device, such as Interview 2.0 USB (XLR8 corporation; http://www.XLR8.com; approximately

$90) can be used. We have confirmed Interview 2.0 USB can work with blue and white

PowerMac G3, PowereMac G4 or iMac. Some iMacs have incompatibility with Interview 2.0,

but software upgrade can resolve the incompatibility. You need to install device driver software

which should come with the capturing device, when you use QuickTime compatible video

capturing device.

(c) Video camera: With Scion LG3 board, any CCD camera which has BNC video output cable

can be used. With Interview 2.0 USB, any CCD camera which has composite video output cable

can be used. However, if you obtain a connector which converts BNC to composite or composite

to BNC, you can use video camera which has either output cable for either device.

(d) Camera mounting tool: You need something which affix the video camera above

behavioral apparatus.

(e) Behavioral Apparatus: Color of behavioral apparatus and coat color of your subjects must

contrast when they are converted to grayscale images. A GamePad, which can use buttons to

which each key can be assigned, is useful, if behavioral apparatus is located far from computer

keyboard. We are using USB Gamepad Pro of Gravis (http://www.gravis.com/) and shareware

USB Overdrive (http://www.usboverdrive.com).

O’Hara & Co supplies necessary hardware and behavioral apparatus described above.

O’Hara & Co

Ekoda 4-28-16, Nakano-ku, Tokyo 165-0022, Japan

Phone: 81-3-3389-2451    Fax: 81-3-3389-2453    E-mail: ohara@apo.co.jp
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Software Configuration
In this chapter, you will create a ‘Template’ folder, which contains a set of default. Every time

you begin a series of experiments, you duplicate this ‘Template’ folder in order to make a folder

for a specific experiment.

 (1) Making ‘Template’ folder and defining region of interest
A. Duplicate original Image WM folder by single-clicking the folder and selecting ‘Duplicate’

from ‘File’ menu of finder.

B. Run Image WM in the ‘Template’ folder.

C. Configure hardware and place behavioral apparatus under video camera. Select ‘Start

Capturing’ from ‘Special’ Menu in order to check if the video capturing is working well or

not.

----Maze configuration setting
D. Select  ‘PrepareField’ from ‘Special’ Menu and you will get ‘Field’ window.

E. Select Rectangle tool from ‘Tools’ window.

F. Make ROI by surrounding the maze in the ‘Field’ window with Rectangle tool.

G. Select ‘SetPoolPosition’ from ‘Special’ Menu.

----Platform configuration setting
H. Select ‘PrepareField’ from ‘Special’ Menu.

I. Select Rectangle tool from ‘Tools’ window.

J. Make region of interest by surrounding the platform location with Rectangle tool.

K. Select ‘SetPFLocation’ from ‘Special’ Menu.

L. Enter the platform number and click ‘OK’. This number should correspond to the quadrant

number to which the platform belongs.

M. Repeat procedure from J to L to set all the four platform locations.
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----Start location setting
N. Select ‘PrepareField’ from ‘Special’ Menu.

O. Select Rectangle tool from ‘Tools’ window.

P. Make region of interest by surrounding the start location with Rectangle tool.

Q. Select ‘SetStartLocation’ from ‘Special’ Menu.

R. Enter the start location number and click ‘OK’. This number should correspond to the

quadrant number to which the start location belongs.

S. Repeat procedure from P to R to set all the four platform locations.

(2) Acquiring optimal threshold value (=’level’), and subject size
A. Configure a camera above pool, fill water in the pool and put white non-toxic paint in it.

B. Put a mouse in the pool.

C. Start Image WM. From Special menu, select ‘PrepareField’. You should see a window whose

title is ‘Field’.

D. Select ‘Threshold’ from Option menu.

E. Place cursor in ‘LUT’ window, which is located left side

of the monitor, and click once.

F. Drag the boundary between white and black to adjust the

threshold level so that the image of the mouse looks

black and all the surface of the pool looks white. Field

outside of the pool does not have to be white, since it

will be excluded by setting oval-shaped ROI when

analysis is conducted.

G. Within ‘Info’ window, which is located lower left side of the monitor, current threshold level

(0-255) is displayed. Take a note about the optimal threshold

value obtained here.

H. Select Oval tool from ‘Tools’ window. Set oval ROI around the

boundary between the wall of the pool and water in the ‘Field’

window. The oval ROI does not have to be precise as long as the

mouse particle is included and no other particles are included in

the ROI.

I. Select ‘Analyze Particles’ from Analyze menu (see NIH Image manual for the details of the

command ‘Analyze Particle’).

J. Select ‘Show Results’ from Analyze menu.

K. Take a note about the amount of area of the particle that corresponds to the image of the

mouse. Use this value for estimating optimal ‘subject size’ at parameter setting.

 (3) Setting default parameters
   In this section, you will set default parameters.

A. Run Image WMH for hidden version (or WMV for visible version) in the template folder.

B.  Select ‘CaptureTrials: Hidden’ (or ‘CaptureTrials: Visible’) from ‘Special’ Menu.
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C. Input ‘1’ and click ‘OK’ to change the frame capturing rate. Input 2.0 to set the frame rate at

2.0 frames per second, and click ‘OK’.

D. Change threshold level (the value you acquired in (2) and subject size (the value you

acquired in (2)) in similar manner to step C, if necessary. When every parameter is OK, input

‘0’ and click ‘OK’.

E. Change, pool size (width and height are actual size of width and height of the pool, or

diameter of the maze), Trace mode (if on, trace will be drawn; usually ‘on’), invert mode (if

on, background should be darker than coat color of animals; usually ‘off’) and inter trial

interval (= duration of keeping mice on the platform after reaching; see notes for details), in

similar manner to step C and D, if necessary. When every parameter is OK, input ‘0’ and

click ‘OK’.

F. Change perimeter distance (distance from wall to define ‘perimeter’), duration of a trial

(usually 60 or 90 sec) and number of trials per mouse in a day in similar manner to step C

and D, if necessary. When every parameter is OK, input ‘0’ and click ‘OK’.

G. When you are asked ‘Enter Session Name’, click ‘Cancel’.

Conducting Experiments
(1) Preparing a folder for an experiment
You need to create a folder only once before a series of experiment begins. This folder is a

personalized one, whose set of parameters will not be affected by the changes of parameters in

other Image WM folders.
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A. Duplicate Image WMH template for hidden version (or Image WMV template for visible

version) by single-clicking the folder and selecting ‘Duplicate’ from ‘File’ menu of finder.

B. Rename the name of the folder (ex. ‘Image WM (XX KO Exp1)’).

(2) Preparing reference file
You need to create reference file only once before a series of experiment begins (Hidden version

only)

A. Run ‘Image WMH’ in the folder you created.

B. Select ‘New’ from ‘File’ menu.

C. Click ‘Text’, enter file name of the reference file in ‘Title’ (ex. ‘XX E1.ref’), and click “OK’.

D. Enter identification name of each mouse in first column and enter target platform number for

each mouse in second column. First and second column should be separated by a space.

Enter ‘Return’ after inputting a line. The sequence of the mice does not have to be identical

to the sequence of the actual trials in the experiment.

E. Select ‘Save As’ from ‘File’ menu. Save the file into the ‘References’

folder under the folder you created in (1). The reference file you

created here will be used in all trials in this experiment as long as the

locations of target platform are not changed.

(3) Running a session
A. Run ‘Image WMH’ in the folder you created (ex. ‘Image WMH (XX

KO Exp1)’).

B. Select ‘CaptureTrials: Hidden’ or ‘CaptureTrials: Visible’ in ‘Special’ menu.

C. Enter session name when you are asked ‘Enter Session Name’ (ex. ‘D1’), and click ‘OK’.

D. Enter reference file name when you are asked ‘Enter Reference File Name’ (ex. ‘X

XE1.ref’), and click ‘OK’ (Hidden version only).

E. Enter start location file when you are asked ‘Enter Start Location File’ (ex. ‘seq1’), and click

‘OK’. See Notes chapter for the definition and details of start location file.
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F. Check if all the parameters displayed in ‘Info’ window are correct. If not, correct the

parameters, as instructed in ‘Software Configuration’ chapter. If they are correct, enter ‘0’,

and click ‘OK’.

G. Enter ‘y’ or ‘n’, when you are asked, ‘Are you doing transfer test today (y or n) ?’(Hidden

version only)

H. If you conduct transfer test (=probe test without platform), enter number of trial in which the

transfer test will be conducted. If you input ‘5’ here, for example, the trial 1-4 will be training

trials and trial 5 will be transfer test. If you conduct only transfer test and no training, enter

‘1’. (Hidden version only)

I. Enter subject name (ex. ‘x100’) when you are asked

‘Enter Subject Name’. This name should be contained

in the reference file you are using.

J. Enter trial number (ex. ‘1’), when you are asked

‘Enter trial number for [subject name]’. Name of an

image file for a trial will be combination of subject name and

the trial number, connected by ‘-‘. In this example, image file

which will be stored in the session name folder in ‘Images’

folder will be ‘x100-1’. After entering trial number, click

‘OK’.

K. A window named ‘Maze’ will appear. In this window,

configuration of water maze will be displayed. Make sure that

1. the maze fit in the circle indicated, and

2. platform is located at the place indicated by letters ‘PF’.
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L. Put the subject at the location indicated by letter ‘S’ with its head directed toward the wall

and quickly move out of the video field. Click once or press the button which corresponds to

mouse click of game pad in order to start capturing a trial.

M. Immediately after the subject reach the platform, press ‘option’ key or press the button which

corresponds to ‘option’ key ‘ to terminate a trial.

N. If you want to continue the session, enter next subject’s name and click ‘OK’. You will go

back to item ‘I’ in this section.  If you want to terminate this session, enter nothing and click

‘OK’. The session file which contains information of the session will be saved in ‘Sessions’

folder. This file will be needed for off-line analysis of the session. Note that the session file

will not be saved automatically, if you click ‘Cancel’ (in this case, you should save the

session file on the monitor manually into ‘Sessions’ folder, by clicking the window and

selecting ‘SaveAs’ in “File’ menu).

L.   You will obtain result files after finishing a session, which are explained below.

Trace stacks: These files are created for each session. These files are named as

‘[session name]’ +’.trace’

and are saved in ‘Traces’ folder. Each slice for a trial is stored sequentially in the stack.

These files are in Tiff format and can be opened or modified in standard application

software, such as Photoshop, Canvas and etc.

Result file (training mode): A result file is created for each session. These files are named

as

‘[session name]’+’.res’

and are saved in ‘Results’ folder. This file contains several kinds of analyzed results for

each subject in a line. These files are in text format. Each column is separated by space.

1st column: Mouse ID.

2nd column: Trial number

3rd column: Latency to reach platform (sec)

4th column: Total distance traveled (cm).

5th column: Average speed (cm/sec).

6th column: Time (sec) spent at perimeter.

7th column: Number of frames in which no particles are recognized.

8th column: Number of frames in which two particles or more are recognized.

9h column: Name of the image file.

Result file (transfer mode): A result file is created for each session. These files are named

as

‘[session name]’+’.probe’

and are saved in ‘Results’ folder. This file contains several kinds of analyzed results for

each subject in a line. These files are in text format. Each column is separated by space.

1st column: Mouse ID.

2nd column: Time spent in the target quadrant (sec)
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3rd column: Time spent in the opposite quadrant (sec)

4th column: Time spent in the left quadrant (sec)

5th column: Time spent in the right quadrant (sec)

6th column: Total distance traveled (cm).

7th column: Average speed (cm/sec).

8th column: Number of crossings above the location where the platform had been

9th column: Number of crossings above the pseudo-platform (opposite)

10th column: Number of crossings above the pseudo-platform (left)

11th column: Number of crossings above the pseudo-platform (right)

12th column: Time (sec) spent at perimeter.

13th column: Number of frames in which no particles are recognized.

14th column: Number of frames in which two particles or more are recognized.

15h column: Name of the image file.

 (4) Analyzing a session (off-line analysis)
A. Run ‘Image WM’ in the folder you created (ex. ‘Image WM (XX KO Exp1)’).

B. Select ‘WaterMazeAnalysis’ in ‘Special’ menu.

C. Enter session name when you are asked ‘Enter Session Name’ (ex. ‘D1’), and click ‘OK’.

D. You will obtain result files, which are explained below.

Trace stacks: These files are created for each session. These files are named as

‘[session name]’ +’.trace’

and are saved in ‘Traces’ folder. Each slice for a trial is stored sequentially in the stack.

These files are in Tiff format and can be opened or modified in standard application

software, such as Photoshop, Canvas and etc.

XY coordinates files : These files are created for each trial. These files are named as

‘[trial name]’+’-‘+’[trail number]’+’.[session name]’

and are saved in ‘XY data’ folder. This file contains XY coordinates of the subject for

each frame. These files are in text format.

1st column: Slice number

2nd column: Particle number

3rd column: X-coordinate.

4th column: Y-coordinate.

5th column: Amount of area (pixels) of the particle.

6th column: Quadrant number

7th column: Distance (cm) to platform

8th column: Distance traveled (cm) from previous frame.

9th column: comment (lost frame: no particles were found; false: The particle was

                   considered to be a false particle)

Result file: A result file is created for each session. These files are named as

‘[session name]’+’.res(off)’

or
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‘[session name]’+’.probe(off)’

and are saved in ‘Results’ folder. The contents of the file are same as the ones created by

online analysis except that trial# is not described in result files of training mode.
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Trouble Shooting
A. ‘Cancel’ button: Some dialogues have ‘Cancel’ button. Avoid clicking ‘Cancel’ button and

try to terminate the program in normal manner. If ‘Cancel’ button is clicked, no files are

automatically saved and you have to save the result files on screen manually, if necessary.

B. Many ‘Multiple Particles’ frames:
1. Threshold level could be lower than optimal value. Try to increase threshold level.

2. The range of subject size is too large. Try to reduce the range by increasing minimum

value and/or decreasing maximum value.

C. Many ‘No Particles’ frames:
1. Threshold level could be higher than optimal value. Try to reduce threshold level.

2. The range of subject size is too small. Try to enlarge the range by decreasing minimum

value and/or increasing maximum value.

D. You obtained an error message, ‘Subject name could not be found in reference file’:
Check if there are no junk characters around subject name and platform number in the

reference file. Such junk characters can interfere the program to acquire subject name.

Sometimes you can see such junk character, if any, by opening the file using word processor,

such as Microsoft Word.

E. You obtained an error message, ‘If you got a File I/O error message, you should make a
folder with session name as its name under Images folder’: Image files are stored in the

folder that has a session name as its file name under ‘Images’ folder. You need to create such

folder before a session begins. However, there are 30 folders whose names are ‘D1’ to ‘D30’

in the Images folder of template folder. Therefore, you do not have to create such folder as

long as you use ‘D1’-‘D30’ as the session name.

F. Any feedback, comments or questions will be welcomed on bugs of the software, wrong
description in this manual, potential improvement and etc. Send e-mail to
tsuyoshi.miyakawa@mcmail.vanderbilt.edu or tsuyoshi@mac.com

Notes
A. Target platform location: Use more than one platform locations and assign them to each

mouse in counter-balanced manner. Original natural preference for some specific location

could confound the results.

B. Mice could use intra-maze cue(s): Some mice can use intra-maze cue(s), such as scratch on

the wall, when maze is fixed across trials. Rotate the maze occasionally with the spatial

location of the target fixed, in order not to allow them to use this strategy.

C. How to stop a program: You can stop a program by typing command + ‘.’. In this case, you

need to save result files manually, if you need those files.

D. ITI: This value designates ‘Inter Trial Interval’. After the subject reach platform, the count

down starts and a beep will be made after this time of this ITI has passed. Upon hearing this

beep, you remove the subject from platform and conduct next trial. Therefore, it does not
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literally mean ‘ITI’ but time for keeping the subject on the platform. Actual ITI is the

duration of this ‘ITI’ plus the time between removal of the subject and the beginning of next

trial.

E. Perimeter: The definition of perimeter is as follows. The center and radius of the pool is

calculated from the defined ROI. Note that the pool is assumed to be circle. When the subject

is outside of the circle whose radius is the radius of the pool minus the defined distance from

the wall, the subject is considered to be in perimeter.

F. Start location file: Start location files are stored in ‘Parameters’ folder. There are 6 built-in

start location files (seq1-seq6). These text files contain the information on the sequence of

start locations, which are relative to platform location. Start location file should be changed

every day. For example, ‘Seq1’ is for day 1, ‘Seq2’ is for day 2, ‘Seq3’ is for day 3 and so

on. The definition of the start location file is as follows.

1: Left to the platform

2: Opposite to the platform

3: Right to the platform

For example, if a file’s content is

‘2 1 2 3’,

then the first trial starts from the location opposite to the platform, the second starts from the

location left to the platform, the third trial starts from the location left to the platform, and the

4th trial starts from the location right to the platform.

You can create your own start location files with the definition. Each figure in the file should

be separated by a space.


